Trying to compile glib-2.0.1

Find out how to get that @*&^$&@ thing to compile!

Trying to compile glib-2.0.1

Postby thieumf » Fri Apr 15, 2005 11:06 am

Hi, I'm a newbie in Unix world and trying to compile glib-2.0.1 in order to compile later cssed-3...
Everything went well so far, I had no error whith ./configure, but when I try to make, I have this error message:

"../libtool: line 1: test: too many arguments
gcc -dynamiclib -undefined suppress -o .libs/libglib- garray.lo gasyncqueue.lo gbacktrace.lo gbsearcharray.lo gcache.lo gcompletion.lo gconvert.lo gdataset.lo gdate.lo gdir.lo gerror.lo gfileutils.lo ghash.lo ghook.lo giochannel.lo glist.lo gmain.lo gmarkup.lo gmem.lo gmessages.lo gnode.lo gpattern.lo gprimes.lo gqsort.lo gqueue.lo grel.lo grand.lo gscanner.lo gshell.lo gslist.lo gstrfuncs.lo gstring.lo gthread.lo gthreadpool.lo gtimer.lo gtree.lo guniprop.lo gutf8.lo gunibreak.lo gunicollate.lo gunidecomp.lo gutils.lo giounix.lo gspawn.lo -all_load libcharset/.libs/ -L/usr/lib libcharset/.libs/ -L/usr/local/lib -lc -liconv -lintl -lc -install_name /usr/local/lib/libglib-2.0.0.dylib
ld: -undefined error or -undefined define_a_way must be used when -twolevel_namespace is in effect
/usr/bin/libtool: internal link edit command failed
make[3]: *** [] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive-am] Error 2"

Does any one know what's the problem ?
Posts: 1
Joined: Fri Apr 15, 2005 7:00 pm
Location: france

Return to Compile Problems

Who is online

Users browsing this forum: No registered users and 2 guests