Using xmms

Discuss installation and usage of the packages from macosx.forked.net.

Using xmms

Postby apex » Thu Aug 23, 2001 4:38 pm

Once you have installed all the required packages for xmms you must start the esound daemon (esd). <BLOCKQUOTE><font size="1" face="Verdana, Helvetica, sans-serif">code:</font><HR><pre>esd -port 16001</pre>[/quote]

Now that esd is running, start xmms and open the preferences. Select eSound as your audio output plugin and make sure it is using port 16001.
apex
 
Posts: 355
Joined: Sun Aug 05, 2001 7:00 pm

Re: Using xmms

Postby Colddiver » Fri Aug 24, 2001 4:35 pm

First, let me start by saying thank you all for porting so many apps to Darwin. It is really cool to learn unix on the Mac without having to repartition, reboot and pray (my previous experiences with linuxppc were not so great).

Regarding XMMS, I tried the trick you mention but it does not seem to be working here... I always get the "Please chack that your output plugin is correct, no other program is blocking the soundcard and soundcard is properly configured" alert...

What other program would block the soundcard?

When I start esd, I do get the init tones so that seems to be fine...

Thanks,

Colddiver
Colddiver
 
Posts: 5
Joined: Fri Aug 24, 2001 7:00 pm
Location: Canada

Re: Using xmms

Postby Colddiver » Fri Aug 24, 2001 6:41 pm

Things are worse now... I did many install for darwin recently and I was careless enough to delete the content of /usr/bin (yeah... I know). I reinstalled OS X and everything else but now, when I want to run XMMS, this is what I get:

** CRITICAL **: setup_ctrlsocket(): Failed to assign /var/tmp/xmms_username.0 to a socket (Error: Permission denied)

I have never had that problem before I reinstalled X so I must assume that before that, the tmp directory that was used was not the /var/tmp...

Other apps complain about that too... How can I fix this?
Colddiver
 
Posts: 5
Joined: Fri Aug 24, 2001 7:00 pm
Location: Canada

Re: Using xmms

Postby Colddiver » Sat Aug 25, 2001 7:06 am

Well... I reinstalled esound and it now works... I have to run it as root though because of the above problem...

Colddiver
Colddiver
 
Posts: 5
Joined: Fri Aug 24, 2001 7:00 pm
Location: Canada

Re: Using xmms

Postby apex » Sat Aug 25, 2001 3:26 pm

yes, running a daemon as root is standard operating procedure in unix.
apex
 
Posts: 355
Joined: Sun Aug 05, 2001 7:00 pm

Re: Using xmms

Postby Colddiver » Tue Aug 28, 2001 7:33 am

Well... It didn't work for long... I now get this each time I try to run esd (either as root or normal user) and XMMS just hang badly if I try to play anything:

- accepting connections on port 16001
Audio device open for 44.1Khz, stereo, 16bit failed
Trying 44.1Khz, 8bit stereo.
Audio device open for 44.1Khz, stereo, 8bit failed
Trying 48Khz, 16bit stereo.
Audio device open for 44.1Khz, stereo, 8bit failed
Trying 22.05Khz, 8bit stereo.
Audio device open for 22.05Khz, stereo, 8bit failed
Trying 44.1Khz, 16bit mono.
Audio device open for 44.1Khz, mono, 8bit failed
Trying 22.05Khz, 8bit mono.
Audio device open for 22.05Khz, mono, 8bit failed
Trying 11.025Khz, 8bit stereo.
Audio device open for 11.025Khz, stereo, 8bit failed
Trying 11.025Khz, 8bit mono.
Audio device open for 11.025Khz, mono, 8bit failed
Trying 8.192Khz, 8bit mono.
Audio device open for 8.192Khz, mono, 8bit failed
Trying 8Khz, 8bit mono.
Sound device inadequate for Esound. Fatal.

It did work but very briefly... Briefly enough to give me a taste of it and to make me want it to work again!

Colddiver
Colddiver
 
Posts: 5
Joined: Fri Aug 24, 2001 7:00 pm
Location: Canada

Re: Using xmms

Postby bmann » Tue Sep 04, 2001 1:46 am

Works fine for me. Could be down to which model of Mac/motherboard you're running....

I've got a Yikes/PCI G4 400Mhz, and here' the response from running esd:

<BLOCKQUOTE><font size="1" face="Verdana, Helvetica, sans-serif">code:</font><HR><pre>
using device Built-in audio controller for output:
with sample rate 44100.000000, 2 channels and 32-bit sample
using device Built-in audio controller for input:
with sample rate 44100.000000, 2 channels and 32-bit sample
</pre>[/quote]

Of course, I still don't have xmms running [img]images/icons/frown.gif"%20border="0[/img] ( <A HREF="http://macosx.forked.net/cgi-bin/ultimatebb.cgi?ubb=get_topic&f=2&t=000018" TARGET=_blank>http://macosx.forked.net/cgi-bin/ultimatebb.cgi?ubb=get_topic&f=2&t=000018</A> ), but that's due to other problems

-- Boris

[ September 03, 2001: Message edited by: Boris Mann ]
bmann
 
Posts: 4
Joined: Mon Sep 03, 2001 7:00 pm
Location: Ottawa, ON, Canada

Re: Using xmms

Postby Obscure2a8 » Wed Sep 12, 2001 10:00 pm

I'm having problems with XMMS as well. ESD works properly and gives the test tones when run as root. XMMS fires up properly, but is unable to open the sound device (it's configured to use ESD, I've tried running "sudo esd -port 16001 &" but no dice! It can't interface with ESD for some reason... Any ideas?

-Obscurian
Obscure2a8
 
Posts: 10
Joined: Tue Sep 11, 2001 7:00 pm

Re: Using xmms

Postby cutter » Sat Sep 22, 2001 11:27 pm

poor apex...seems like he's the only one here who has any solutions. I'm also having the same problem as colddiver is trying to get eSound to work...
cutter
 
Posts: 2
Joined: Sat Sep 22, 2001 7:00 pm

Re: Using xmms

Postby cutter » Sat Sep 22, 2001 11:28 pm

poor apex...seems like he's the only one here who has any solutions. I'm also having the same problem as colddiver is trying to get eSound to work...
cutter
 
Posts: 2
Joined: Sat Sep 22, 2001 7:00 pm

Re: Using xmms

Postby Obscure2a8 » Sun Sep 23, 2001 6:59 pm

So I've had a little (limited) luck running XMMS and ESD. I've had to specify tcp ports by running
esd -tcp &
and then starting xmms. I get sound output but it's choppy and doesn't play correctly. I am wondering if this is because of the tcp bit. I read somewhere that esd is normally supposed to interface through the socket at /tmp/.esd/socket
Try out the -tcp flag and see if it helps. Anybody have an idea why playback would be so choppy?

-Obscurian
Obscure2a8
 
Posts: 10
Joined: Tue Sep 11, 2001 7:00 pm

Re: Using xmms

Postby apex » Mon Sep 24, 2001 6:44 pm

Obscurion-
Did you configure xmms to use esound as its output plugin, and is it also using port 16001? (this is when you are not using the -tcp option)
apex
 
Posts: 355
Joined: Sun Aug 05, 2001 7:00 pm

Re: Using xmms

Postby hypoflux » Sat Oct 20, 2001 2:14 pm

here's some tips that SHOULD get XMMS and esd working properly, since I saw no one posted this in regards to this problem.

Run 'esdcat /usr/libexec/config.guess' or any other big file (a big tar ball maybe [img]images/icons/grin.gif"%20border="0[/img]) if you hear grating white noise really quick, esd SHOULD work right for you. If you get no out from that. run 'esd &' and watch the output - if all looks normal you should something in regards to using outputdevice etc

Also, check in the preferences of xmms that the output plugin is set for esd (by default, that i've seen, it starts with some diskwriter plugin)

if you're still getting long pauses, or no sound output. check the permissions on /tmp/.esd and /tmp/.esd/socket they should be owned your normal user account. If they are not owned by you, kill ESD if it's running (check by doing a 'ps aux | grep esd', then remove the directory as the root user (sudo rm -fr /tmp/.esd) then start esd again (run esd as your normal user, not the superuser, esd was meant to be run on a per user, per need basis, not as root)

also, you do not need to run esd with the -port and -tcp switches if you want to run esd clients on another computer on your network. etc.

~Eric
hypoflux
 
Posts: 4
Joined: Sat Oct 20, 2001 7:00 pm
Location: Florida

Re: Using xmms

Postby v0id7 » Wed Nov 07, 2001 12:01 pm

when i start esd it makes a cool sound that makes me think its working but i still get no sound in xmms even though the esound output plugin is selected...when i start esd i type "esd &" i do this as a normal user and xmms gives me a dilog saying "please check that:
1) you have the correct sound output plugin selected

2) you have no other programs blocking the sound card

3) your sound card is configured correctly"

if it matters i have a new g4
please help, thanks in advance!
v0id7
 
Posts: 1
Joined: Wed Nov 07, 2001 8:00 pm
Location: Everywhere

Re: Using xmms

Postby ThanatosX » Wed Dec 05, 2001 2:19 pm

I have gotten it all to work fine... with some messing about. The bigger prob I have is that the sound is so jumpy it is unusable. I put this down to my computer being to slow. But still I can run MP3 in mpg123 and they play okay. I know this is a different thing but are there any ways to optimise the way my comp plays in XMMS?

I have a Blue and White G3 350Mhz, 192Megs RAM running OSX 10.1.1.... suggestions?
ThanatosX
 
Posts: 5
Joined: Wed Dec 05, 2001 8:00 pm
Location: Scotland

Next

Return to Ported Packages

Who is online

Users browsing this forum: Google [Bot] and 1 guest

cron