perlcc failure

Everything else.

perlcc failure

Postby matthewg42 » Sun May 19, 2002 11:46 am

Hi there,

Has anyone else had problems running perlcc? I get problems with even the most elementary scripts, like this:

> perlcc test.pl

--------------------------------------------------------------------------------
Compiling test.pl:
--------------------------------------------------------------------------------
Making C(test.pl.c) for test.pl!
perl -I/System/Library/Perl/darwin -I/System/Library/Perl -I/sw/lib/perl5/darwin -I/sw/lib/perl5 -I/System/Library/Perl/darwin -I/System/Library/Perl -I/Library/Perl/darwin -I/Library/Perl -I/Library/Perl -I/Network/Library/Perl/darwin -I/Network/Library/Perl -I/Network/Library/Perl -I. -MB::Stash -c test.pl
perl -I/System/Library/Perl/darwin -I/System/Library/Perl -I/sw/lib/perl5/darwin -I/sw/lib/perl5 -I/System/Library/Perl/darwin -I/System/Library/Perl -I/Library/Perl/darwin -I/Library/Perl -I/Library/Perl -I/Network/Library/Perl/darwin -I/Network/Library/Perl -I/Network/Library/Perl -I. -MO=C,-umain,-uDB,-uExporter,-uExporter::Heavy,-uTerm,-uTerm::Cap,-uwarnings,-uwarnings::register,-ustrict,-uattributes,-ure,-uvars,-uText,-uText::Tabs,-uText::Wrap,-uCarp,-uCarp:: Heavy,-uFile,-uFile::Basename test.pl
Starting compile
Walking tree
Exporter saved (it is in Text::Wrap's @ISA)
Prescan
Saving methods
Bootstrap attributes test.pl
Writing output
Loaded B
Loaded IO
Loaded Fcntl
test.pl syntax OK
Compiling C(test) for test.pl!
perl -I/System/Library/Perl/darwin -I/System/Library/Perl -I/sw/lib/perl5/darwin -I/sw/lib/perl5 -I/System/Library/Perl/darwin -I/System/Library/Perl -I/Library/Perl/darwin -I/Library/Perl -I/Library/Perl -I/Network/Library/Perl/darwin -I/Network/Library/Perl -I/Network/Library/Perl -I. /tmp/test.pl.tst
cc -g -pipe -pipe -fno-common -no-cpp-precomp -flat_namespace -DHAS_TELLDIR_PROTOTYPE -fno-strict-aliasing -I/System/Library/Perl/darwin/CORE -o test test.pl.c -L/System/Library/Perl/darwin/CORE -lperl -lm -lc
/usr/bin/ld: Undefined symbols:
_boot_DynaLoader
ERROR: In compiling code for test.pl.c !


I can't find this _boot_DynaLoader symbol in any /usr/lib/*dylib files.

Anyone know how to solve this?

Cheers,
--
Matthew
matthewg42
 
Posts: 3
Joined: Sun May 19, 2002 7:00 pm
Location: Düsseldorf, Germany / UK

Return to General Discussion

Who is online

Users browsing this forum: Google [Bot] and 3 guests

cron