enabling tftp Server

Everything else.

enabling tftp Server

Postby janderson » Thu Oct 11, 2001 8:55 pm

I hope you don't mind I have a duplicate post on Macosx.org, but does anyone know how to enable the tftp server in OSX and specify a directory for which it uses?

Thanks,
Joe
janderson
 
Posts: 21
Joined: Mon Sep 10, 2001 7:00 pm
Location: Dallas

Re: enabling tftp Server

Postby dglewis » Thu Oct 11, 2001 10:42 pm

I've never run a tftpd server before but I just did a quick `man -k tftp`. Do that, then look at the man page for tftpd. There it explains most everything.

vi /etc/inetd.conf and uncomment the tftpd line, adding `-s ` to the command. This changes the root directory to the second argument: `/private/tftpboot`... which is the directory that it uses.

After this, you probably have to do a kill -HUP on inetd to get it to read in the inetd.conf changes.

I'm curious, if you don't mind me asking, what you're going to use it for. I believe it was originally designed for diskless workstations that need to copy an image on startup or something.
Dan
dglewis
 
Posts: 27
Joined: Mon Sep 17, 2001 7:00 pm

Re: enabling tftp Server

Postby janderson » Thu Oct 11, 2001 11:47 pm

Man I feel like an idiot... I was looking at the wrong man pages... I kept looking over the man pages for tftp commands rather than the server.

Thanks pointing the way.

-Joe
janderson
 
Posts: 21
Joined: Mon Sep 10, 2001 7:00 pm
Location: Dallas

Re: enabling tftp Server

Postby janderson » Fri Oct 12, 2001 12:02 am

I forgot to tell you why I was using it... I'm a network engineer and some of my routers and switches grab their code upgrades from a tftp server. I don't have a dedicated tftp server on my LAN so I usually just fire one up on my laptop for temporary purposes. tftp does seem to be phasing out in some of the newer equipment I've been using. Probably due to it using UDP rather than TCP. UDP offers no guarantees that the data will get to it's destination so occasionally your code upgrade will fail and you'll have to start from scratch... I'm babbling now. Hope this answers your question.

-Joe
janderson
 
Posts: 21
Joined: Mon Sep 10, 2001 7:00 pm
Location: Dallas

Re: enabling tftp Server

Postby dglewis » Fri Oct 12, 2001 1:48 am

Well I hope you're having better luck than me. For kicks I tried to get it running. I just used the factory setting there on the directory. After reading in the inetd.conf, I ran tftp localhost...nothing... timeout w/out connect. So I pgrep'd looking for it and it never showed. Maybe some other service needs to be set? dunno - let me know how it turns out, I'm going to stop bothering with this so I can focus on the weekend and some suds

gl
Dan
dglewis
 
Posts: 27
Joined: Mon Sep 17, 2001 7:00 pm

Re: enabling tftp Server

Postby janderson » Fri Oct 26, 2001 3:30 am

I didn't get a chance to try this out until recently, but it worked. All I did was uncomment the tftp line in my /etc/inetd.conf file.

tftp dgram udp wait nobody /usr/libexec/tcpd tftpd /Users/myusername/Temp/tftp

I also changed the directory to one of my preference... Finally I restarted inetd. That's it.
janderson
 
Posts: 21
Joined: Mon Sep 10, 2001 7:00 pm
Location: Dallas

Re: enabling tftp Server

Postby <krisolson> » Sat Jul 13, 2002 9:13 pm

how do i save my edited changed to the inetd.conf file? w /etc/inetd.conf wont do it. Also after i have made the changes, how do I reboot inetd?
<krisolson>
 


Return to General Discussion

Who is online

Users browsing this forum: Google [Bot] and 3 guests

cron