NetHack 3.3.1 Port on 10.2

Discuss installation and usage of the packages from

NetHack 3.3.1 Port on 10.2

Postby <rbates> » Tue Sep 10, 2002 2:05 am

I am unable to get NetHack 3.3.1 port to work on MacOS X 10.2. After I run it through the terminal using the "/usr/games/nethack" command I receive an error. It seems that the _ospeed symbol was not defined. I have also tried compiling the source and I get several symbols (including the _ospeed symbol) which are not defined. Has anyone successfully installed NetHack on 10.2? If so, is there a work around to this error message? Thanks.

Re: NetHack 3.3.1 Port on 10.2

Postby <ad> » Wed Sep 11, 2002 2:00 am

I compiled the latest release (3.4.0) from source I got from The Makefiles generated with "sh sys/unix/" worked for me except I had to change -ltermlib to -lcurses in src/Makefile

Re: NetHack 3.3.1 Port on 10.2

Postby <rbates> » Thu Sep 12, 2002 9:20 pm

Thanks! It compiled perfectly with that fix.

Re: NetHack 3.3.1 Port on 10.2

Postby jstrout » Thu Mar 13, 2003 7:38 pm

So is somebody going to update the archive? If I have to go to the original source and compile it myself, of what use is
Posts: 2
Joined: Thu Mar 13, 2003 8:00 pm
Location: San Diego, CA

Return to Ported Packages

Who is online

Users browsing this forum: No registered users and 2 guests